After selecting an employee from the menu and paying that employee, clicking on the save and close button responded with the message "operation must use an updateable query" in version 7.0.25
I downloaded the latest version 7.0.34 and now get an error message "An error occurred in the application"